Cumulative Security Update for Internet Explorer (MS15-124)

ITS Advisory Number: 
2015-143
Date(s) Issued: 
Tuesday, December 8, 2015
Subject: 
Cumulative Security Update for Internet Explorer (MS15-124)
Overview: 

This security update resolves vulnerabilities in Internet Explorer. The most severe of the vulnerabilities could allow remote code execution if a user views a specially crafted webpage using Internet Explorer. An attacker who successfully exploited these vulnerabilities could gain the same user rights as the current user. Customers whose accounts are configured to have fewer user rights on the system could be less impacted than those who operate with administrative user rights.

Systems Affected: 
  • Internet Explorer 11 on Windows 10
  • Internet Explorer 11
  • Internet Explorer 10
  • Internet Explorer 9
  • Internet Explorer 8
  • Internet Explorer 7
RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
BUSINESS
Large and medium business entities: 
High
Small business entities: 
High
Home Users: 
High
Description: 

The security update addresses the following vulnerabilities:

  • Internet Explorer Memory Corruption Vulnerabilities [CVE-2015-6083, CVE-2015-6134, CVE-2015-6140, CVE-2015-6141, CVE-2015-6142, CVE-2015-6143, CVE-2015-6145, CVE-2015-6146, CVE-2015-6147, CVE-2015-6148, CVE-2015-6149, CVE-2015-6150, CVE-2015-6151, CVE-2015-6152, CE-2015-6153, CVE-2015-6154, CVE-2015-6155, CVE-2015-6156, CVE-2015-6158, CVE-2015-6159, CVE-2015-6160, CE-2015-6162]
  • Microsoft Browser XSS Filter Bypass Vulnerabilities: [CVE-2015-6138, CVE-2015-6144]
  • Internet Explorer XSS Filter Bypass Vulnerability: [CVE-2015-6164]
  • Internet Explorer Information Disclosure Vulnerability: [CVE-2015-6157]
  • Scripting Engine Information Disclosure Vulnerability: [CVE-2015-6135]
  • Scripting Engine Memory Corruption Vulnerability: [CVE-2015-6136]
  • Microsoft Browser Elevation of Privilege Vulnerability: [CVE-2015-6139]
  • Microsoft Browser ASLR Bypass: [CVE-2015-6161]

These vulnerabilities could allow remote code execution or an elevation of privilege if a user views a specially crafted webpage in Internet Explorer. An attacker who successfully exploits this vulnerability could gain the same user rights as the current user. Depending on the privileges associated with the user, an attacker could install programs; view, change, or delete data; or create new accounts with full user rights.

Actions: 
  • After appropriate testing, apply appropriate patches provided by Microsoft to vulnerable systems.
  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.
  • Remind users not to visit untrusted websites or follow links provided by unknown or untrusted sources.
  • Do not open email attachments from unknown or untrusted sources or suspicious emails from trusted sources.
References: 

Microsoft:

https://technet.microsoft.com/library/security/MS15-124

CVE:

 

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6083

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6134

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6135

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6136

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6138

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6139

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6140

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6141

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6142

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6143

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6144

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6145

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6146

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6147

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6148

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6149

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6150

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6151

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6152

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6153

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6154

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6155

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6156

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6157

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6158

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6159

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6160

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6161

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6162

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6163

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6164