Multiple Vulnerabilities in Google Android OS Could Allow for Arbitrary Code Execution

ITS Advisory Number: 
2019-122
Date(s) Issued: 
Tuesday, November 5, 2019
Subject: 
Multiple Vulnerabilities in Google Android OS Could Allow for Arbitrary Code Execution
Overview: 

Multiple vulnerabilities have been discovered in the Google Android operating system (OS), the most severe of which could allow for arbitrary code execution. Android is an operating system developed by Google for mobile devices, including, but not limited to, smartphones, tablets, and watches. Successful exploitation of the most severe of these vulnerabilities could allow for arbitrary code execution within the context of a privileged process.

 

THREAT INTELLIGENCE:

There are currently no reports of these vulnerabilities being exploited in the wild.

 

Systems Affected: 
  • Android OS builds utilizing Security Patch Levels issued prior to November 5, 2019.
RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
BUSINESS
Large and medium business entities: 
High
Small business entities: 
High
Home Users: 
High
Description: 

Multiple vulnerabilities have been discovered in Google Android OS, the most severe of which could allow for arbitrary code execution within the context of a privileged process. Details of these vulnerabilities are as follows: 

  • An arbitrary code vulnerability in Library. (CVE-2019-2201)

  • An information disclosure vulnerability in Kernel components. (CVE-2019-11833)

  • Multiple arbitrary code vulnerabilities in System. (CVE-2019-2204, CVE-2019-2205, CVE-2019-2206)

  • Multiple elevation of privilege vulnerabilities in Framework. (CVE-2019-2192, CVE-2019-2193, CVE-2019-2195, CVE-2019-2199)

  • Multiple elevation of privilege vulnerabilities in Kernel components. (CVE-2019-2213, CVE-2019-2214, CVE-2019-2215)

  • Multiple elevation of privilege vulnerabilities in Media framework. (CVE-2019-2202, CVE-2019-2203)

  • Multiple elevation of privilege vulnerabilities in System. (CVE-2019-2036, CVE-2019-2207, CVE-2019-2233)

  • Multiple information disclosure vulnerabilities in Framework. (CVE-2019-2196, CVE-2019-2197, CVE-2019-2198, CVE-2019-2211)

  • Multiple information disclosure vulnerabilities in System. (CVE-2019-2208, CVE-2019-2209, CVE-2019-2212)

  • Multiple vulnerabilities in Qualcomm closed-source components. (CVE-2019-10484, CVE-2019-10485, CVE-2019-10493, CVE-2019-10511, CVE-2019-10559, CVE-2019-2288, CVE-2019-2319, CVE-2019-2320, CVE-2019-2321, CVE-2019-2337, CVE-2019-2338)

  • Multiple vulnerabilities in Qualcomm components. (CVE-2019-10545, CVE-2019-10571, CVE-2019-2310) 

Successful exploitation of the most severe of these vulnerabilities could allow for arbitrary code execution in the context of a privileged process. These vulnerabilities could be exploited through multiple methods such as email, web browsing, and MMS when processing media files. 

 

Actions: 
  • After appropriate testing, immediately apply the updates provided by Google Android or mobile carriers to vulnerable systems.

  • Remind users to only download applications from trusted vendors in the Play Store.

  • Remind users not to visit un-trusted websites or follow links provided by unknown or un-trusted sources.

  • Inform and educate users regarding threats posed by hypertext links contained in emails or attachments, especially from un-trusted sources.

References: 

Google Android:
http://source.android.com/security/bulletin/2019-11-01.html

CVE:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2036
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2192
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2193
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2195
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2196
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2197
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2198
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2199
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2201
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2202
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2203
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2204
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2205
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2206
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2207
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2208
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2209
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2211
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2212
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2213
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2214
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2215
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2233
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2288
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2310
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2319
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2320
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2321
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2337
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2338
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10484
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10485
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10493
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10511
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10545
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10559
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10571
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11833