Multiple Vulnerabilities in Google Android OS Could Allow for Arbitrary Code Execution

ITS Advisory Number: 
2020-001
Date(s) Issued: 
Tuesday, January 7, 2020
Subject: 
Multiple Vulnerabilities in Google Android OS Could Allow for Arbitrary Code Execution
Overview: 

Multiple vulnerabilities have been discovered in the Google Android operating system (OS), the most severe of which could allow for remote code execution. Android is an operating system developed by Google for mobile devices, including, but not limited to, smartphones, tablets, and watches. Successful exploitation of the most severe of these vulnerabilities could allow for arbitrary code execution within the context of a privileged process. Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

 

THREAT INTELLIGENCE:

There are currently no reports of these vulnerabilities being exploited in the wild.

 

Systems Affected: 
  • Android OS builds utilizing Security Patch Levels issued prior to January 5, 2020.
RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
BUSINESS
Large and medium business entities: 
High
Small business entities: 
High
Home Users: 
High
Description: 

Multiple vulnerabilities have been discovered in Google Android OS, the most severe of which could allow for arbitrary code execution within the context of a privileged process. Details of these vulnerabilities are as follows:

 

  • An arbitrary code vulnerability in Kernel components. (CVE-2019-17666)
  • An arbitrary code vulnerability in Media framework. (CVE-2020-0002) Media codecs (CVE-2020-0002)
  • A Denial of service vulnerabilities in Framework. (CVE-2020-0004)
  • Multiple elevation of privilege vulnerabilities in Framework. (CVE-2020-0001, CVE-2020-0003)
  • Multiple elevation of privilege vulnerabilities in Kernel components. (CVE-2018-20856, CVE-2019-15214, CVE-2020-0009)
  • Multiple information disclosure vulnerabilities in System. (CVE-2020-0006, CVE-2020-0007, CVE-2020-0008)
  • Multiple vulnerabilities in Qualcomm closed-source components. (CVE-2019-10532, CVE-2019-10548, CVE-2019-10578, CVE-2019-10579, CVE-2019-10582, CVE-2019-10583, CVE-2019-10611, CVE-2019-14002, CVE-2019-14003, CVE-2019-14004, CVE-2019-14005, CVE-2019-14006, CVE-2019-14008, CVE-2019-14013, CVE-2019-14014, CVE-2019-14016, CVE-2019-14017, CVE-2019-2267)
  • Multiple vulnerabilities in Qualcomm components. (CVE-2019-10602, CVE-2019-10606, CVE-2019-14010, CVE-2019-14034)

 

Successful exploitation of the most severe of these vulnerabilities could allow for arbitrary code execution in the context of a privileged process. These vulnerabilities could be exploited through multiple methods such as email, web browsing, and MMS when processing media files. Depending on the privileges associated with the application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

Actions: 
  • After appropriate testing, immediately apply updates by Google Android or mobile carriers to vulnerable systems.
  • Remind users to only download applications from trusted vendors in the Play Store.
  • Remind users not to visit un-trusted websites or follow links provided by unknown or un-trusted sources.
  • Inform and educate users regarding threats posed by hypertext links contained in emails or attachments, especially from un-trusted sources.
References: 

Google Android:

http://source.android.com/security/bulletin/2020-01-01

 

CVE:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20856

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2267

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10532

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10548

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10558

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10578

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10579

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10581

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10582

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10583

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10585

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10602

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10606

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10611

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11843

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14002

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14003

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14004

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14005

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14006

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14008

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14010

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14013

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14014

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14016

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14017

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14023

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14024

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14034

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14036

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15214

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-17666

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0001

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0002

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0003

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0004

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0006

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0007

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0008

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0009