Multiple Vulnerabilities in Google Chrome Could Allow for Arbitrary Code Execution

ITS Advisory Number: 
2020-017
Date(s) Issued: 
Wednesday, February 5, 2020
Subject: 
Multiple Vulnerabilities in Google Chrome Could Allow for Arbitrary Code Execution
Overview: 

Multiple vulnerabilities have been discovered in Google Chrome, the most severe of which could allow for arbitrary code execution. Google Chrome is a web browser used to access the Internet. Successful exploitation of the most severe vulnerabilities could allow an attacker to execute arbitrary code in the context of the browser. Depending on the privileges associated with the application, an attacker could install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

 

THREAT INTELLIGENCE:

There are currently no reports of these vulnerabilities being exploited in the wild.

 

Systems Affected: 
  • Google Chrome versions prior to 80.0.3987.87

RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
Medium
BUSINESS
Large and medium business entities: 
High
Small business entities: 
Medium
Home Users: 
Low
Description: 

Multiple vulnerabilities have been discovered in Google Chrome, the most severe of which could result in arbitrary code execution. These vulnerabilities can be exploited if a user visits, or is redirected to, a specially crafted web page. Details of the vulnerabilities are as follows:

  • Integer overflow in JavaScript (CVE-2020-6381)

  • Type Confusion in JavaScript (CVE-2020-6382)

  • Multiple vulnerabilities in XML (CVE-2019-18197)

  • Inappropriate implementation in SQLite (CVE-2019-19926)

  • Insufficient policy enforcement in storage (CVE-2020-6385)

  • Multiple vulnerabilities in SQLite (CVE-2019-19880)

  • Out of bounds write in WebRTC (CVE-2020-6387, CVE-2020-6389)

  • Out of bounds memory access in WebAudio (CVE-2020-6388)

  • Out of bounds memory access in streams (CVE-2020-6390)

  • Insufficient validation of untrusted input in Blink (CVE-2020-6391)

  • Insufficient policy enforcement in extensions (CVE-2020-6392)

  • Insufficient policy enforcement in Blink (CVE-2020-6393, CVE-2020-6394)

  • Out of bounds read in JavaScript (CVE-2020-6395)

  • Inappropriate implementation in Skia (CVE-2020-6396)

  • Incorrect security UI in sharing (CVE-2020-6397)

  • Uninitialized use in PDFium (CVE-2020-6398)

  • Insufficient policy enforcement in AppCache (CVE-2020-6399)

  • Inappropriate implementation in CORS (CVE-2020-6400)

  • Insufficient validation of untrusted input in Omnibox (CVE-2020-6401, CVE-2020-6411, CVE-2020-6412)

  • Insufficient policy enforcement in downloads (CVE-2020-6402)

  • Incorrect security UI in Omnibox (CVE-2020-6403)

  • Inappropriate implementation in Blink (CVE-2020-6404, CVE-2020-6413)

  • Out of bounds read in SQLite (CVE-2020-6405)

  • Use after free in audio (CVE-2020-6406)

  • Out of bounds memory access in SQLite (CVE-2019-19923)

  • Insufficient policy enforcement in CORS (CVE-2020-6408)

  • Inappropriate implementation in Omnibox (CVE-2020-6409)

  • Insufficient policy enforcement in navigation (CVE-2020-6410)

  • Insufficient policy enforcement in Safe Browsing (CVE-2020-6414)

  • Inappropriate implementation in JavaScript (CVE-2020-6415)

  • Insufficient data validation in streams (CVE-2020-6416)

  • Inappropriate implementation in installer (CVE-2020-6417) 

Successful exploitation of the most severe of these vulnerabilities could allow an attacker to execute arbitrary code in the context of the browser, obtain sensitive information, bypass security restrictions and perform unauthorized actions, or cause denial-of-service conditions.

 

Actions: 
  • After appropriate testing, immediately apply the stable channel update provided by Google to vulnerable systems.

  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.

  • Remind users not to visit un-trusted websites or follow links provided by unknown or un-trusted sources.

  • Inform and educate users regarding the threats posed by hypertext links contained in emails or attachments especially from un-trusted sources.

  • Apply the Principle of Least Privilege to all systems and services.

 

References: 

Google:
https://chromereleases.googleblog.com/2020/02/stable-channel-update-for-...

CVE:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-18197
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-19880
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-19923
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-19926
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6381
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6382
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6385
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6387
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6388
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6389
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6390
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6391
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6392
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6393
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6394
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6395
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6396
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6397
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6398
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6399
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6400
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6401
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6402
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6403
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6404
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6405
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6406
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6408
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6409
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6410
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6411
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6412
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6413
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6414
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6415
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6416
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6417