Multiple Vulnerabilities in Google Android OS Could Allow for Arbitrary Code Execution

ITS Advisory Number: 
2020-048
Date(s) Issued: 
Thursday, April 9, 2020
Subject: 
Multiple Vulnerabilities in Google Android OS Could Allow for Arbitrary Code Execution
Overview: 

Multiple vulnerabilities have been discovered in the Google Android operating system (OS), the most severe of which could allow for remote code execution. Android is an operating system developed by Google for mobile devices, including, but not limited to, smartphones, tablets, and watches. Successful exploitation of the most severe of these vulnerabilities could allow for remote code execution within the context of a privileged process. Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

 

THREAT INTELLIGENCE:

There are currently no reports of these vulnerabilities being exploited in the wild.

 

Systems Affected: 
  • Android OS builds utilizing Security Patch Levels issued prior to April 5, 2020.

RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
Home Users: 
High
Description: 

Multiple vulnerabilities have been discovered in Google Android OS, the most severe of which could allow for remote code execution within the context of a privileged process. Details of these vulnerabilities are as follows: 

  • Multiple vulnerabilities in Framework that could allow for Escalation of Privileges (CVE-2020-0080, CVE-2020-0081, CVE-2020-0082, CVE-2019-5018)

  • Multiple vulnerabilities in Framework that could allow for Information Disclosure (CVE-2019-8457, CVE-2019-9936)

  • Multiple vulnerabilities in Media framework that could allow for Escalation of Privileges (CVE-2020-0078, CVE-2020-0079)

  • Multiple vulnerabilities in System that could allow for Remote Code Execution (CVE-2020-0070, CVE-2020-0071, CVE-2020-0072, CVE-2020-0073)

  • A vulnerability in Google Play system updates that could allow for Information Disclosure (CVE-2019-2056)

  • A vulnerability in Framework that could allow for Information Disclosure (CVE-2019-2056)

  • Multiple vulnerabilities in Kernel components that could allow for Escalation of Privileges (CVE-2019-19524, CVE-2019-19532, CVE-2019-19807)

  • A vulnerability in FPC components that could allow for Escalation of Privileges (CVE-2020-0076)

  • Multiple vulnerabilities in FPC components that could allow for Information Disclosure (CVE-2020-0075, CVE-2020-0077)

  • Multiple High severity vulnerabilities in Qualcomm components (CVE-2019-14070, CVE-2019-14104, CVE-2019-14122, CVE-2019-14132, CVE-2020-3651)

  • A Critical severity vulnerability in Qualcomm components (CVE-2019-14131)

  • Multiple High severity vulnerabilities in Qualcomm closed-source components (CVE-2019-10483, CVE-2019-10551, CVE-2019-10589, CVE-2019-10608, CVE-2019-10610, CVE-2019-14001, CVE-2019-14007, CVE-2019-14009, CVE-2019-14011, CVE-2019-14012, CVE-2019-14018, CVE-2019-14019, CVE-2019-14020, CVE-2019-14021, CVE-2019-14022, CVE-2019-14033, CVE-2019-14075, CVE-2019-14105, CVE-2019-14127, CVE-2019-14134, CVE-2019-14135, CVE-2020-3651)

  • Multiple Critical severity vulnerabilities in Qualcomm closed-source components (CVE-2019-10575, CVE-2019-10588, CVE-2019-10609, CVE-2019-14110, CVE-2019-14111, CVE-2019-14112, CVE-2019-14113, CVE-2019-14114) 

Successful exploitation of the most severe of these vulnerabilities could allow for remote code execution in the context of a privileged process. These vulnerabilities could be exploited through multiple methods such as email, web browsing, and MMS when processing media files. Depending on the privileges associated with the application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

Actions: 
  • After appropriate testing, immediately apply updates by Google Android or mobile carriers to vulnerable systems.
  • Remind users to only download applications from trusted vendors in the Play Store.
  • Remind users not to visit un-trusted websites or follow links provided by unknown or un-trusted sources.
  • Inform and educate users regarding threats posed by hypertext links contained in emails or attachments, especially from un-trusted sources.

 

References: 

Google Android:
https://source.android.com/security/bulletin/2020-04-01

CVE:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2056
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-5018
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8457
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9936
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10483
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10551
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10575
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10588
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10589
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10608
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10609
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-10610
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14001
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14007
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14009
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14011
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14012
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14018
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14019
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14020
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14021
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14022
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14033
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14070
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14075
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14104
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14105
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14110
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14111
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14112
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14113
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14114
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14122
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14127
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14131
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14132
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14134
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14135
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-19524
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-19532
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-19807
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0070
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0071
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0072
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0073
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0075
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0076
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0077
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0078
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0079
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0080
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0081
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-0082
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-3651