Multiple Vulnerabilities in Adobe Acrobat and Reader Could Allow for Arbitrary Code Execution (APSB18-30)

ITS Advisory Number: 
2018-095
Date(s) Issued: 
Tuesday, October 2, 2018
Subject: 
Multiple Vulnerabilities in Adobe Acrobat and Reader Could Allow for Arbitrary Code Execution (APSB18-30)
Overview: 

Multiple vulnerabilities have been discovered in Adobe Acrobat and Adobe Reader, the most severe of which could allow for arbitrary code execution. Adobe Acrobat and Reader allow a user to view, create, manipulate, print and manage files in Portable Document Format (PDF). Successful exploitation of the most severe of these vulnerabilities could result in the attacker gaining control of the affected system. Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

THREAT INTELLIGENCE:

There are no reports of these vulnerabilities being exploited in the wild.

Systems Affected: 
  • Acrobat DC (Continuous Track) for Windows and macOS version 2018.011.20063 and prior
  • Acrobat Reader DC (Continuous Track) for Windows and macOS version 2018.011.20063 and prior
  • Acrobat 2017 (Classic 2017 Track) for Windows and macOS version 2017.011.30102 and prior
  • Acrobat Reader 2017 (Classic 2017 Track) for Windows and macOS version 2017.011.30102 and prior
  • Acrobat DC (Classic 2015 Track) for Windows and macOS version 2015.006.30452 and prior
  • Acrobat Reader DC (Classic 2015 Track) for Windows and macOS version 2015.006.30452 and prior
RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
Medium
BUSINESS
Large and medium business entities: 
High
Small business entities: 
Medium
Home Users: 
Low
Description: 

Multiple vulnerabilities have been discovered in Adobe Acrobat and Adobe Reader, the most severe of which could allow for arbitrary code execution. The vulnerabilities are as follows:

  • Multiple out-of-bounds vulnerabilities that could lead to arbitrary code execution. (CVE-2018-15955, CVE-2018-15954, CVE-2018-15952, CVE-2018-15945, CVE-2018-15944, CVE-2018-15941, CVE-2018-15940, CVE-2018-15939, CVE-2018-15938, CVE-2018-15936, CVE-2018-15935, CVE-2018-15934, CVE-2018-15933, CVE-2018-15929, CVE-2018-15928, CVE-2018-12868, CVE-2018-12865, CVE-2018-12864, CVE-2018-12862, CVE-2018-12861, CVE-2018-12860, CVE-2018-12759)
  • Multiple out-of-bounds vulnerabilities that could lead to information disclosure. (CVE-2018-15956, CVE-2018-15953, CVE-2018-15950, CVE-2018-15949, CVE-2018-15948, CVE-2018-15947, CVE-2018-15946, CVE-2018-15943, CVE-2018-15942, CVE-2018-15932, CVE-2018-15927, CVE-2018-15926, CVE-2018-15925, CVE-2018-15923, CVE-2018-15922, CVE-2018-12880, CVE-2018-12879, CVE-2018-12878, CVE-2018-12875, CVE-2018-12874, CVE-2018-12873, CVE-2018-12872, CVE-2018-12871, CVE-2018-12870, CVE-2018-12869, CVE-2018-12867, CVE-2018-12866, CVE-2018-12859, CVE-2018-12857, CVE-2018-12856, CVE-2018-12845, CVE-2018-12844, CVE-2018-12843, CVE-2018-12839, CVE-2018-12834, CVE-2018-15968)
  • Multiple heap overflow vulnerabilities that could lead to arbitrary code execution. (CVE-2018-12851, CVE-2018-12847, CVE-2018-12846, CVE-2018-12837, CVE-2018-12836, CVE-2018-12833, CVE-2018-12832)
  • Multiple use after free vulnerabilities that could lead to arbitrary code execution. (CVE-2018-15924, CVE-2018-15920, CVE-2018-12877, CVE-2018-12863, CVE-2018-12852, CVE-2018-12831, CVE-2018-12769)
  • Multiple type confusion vulnerabilities that could lead to arbitrary code execution. (CVE-2018-12876, CVE-2018-12858, CVE-2018-12835)
  • A stack overflow vulnerability that could lead to information disclosure. (CVE-2018-12838)
  • A double free vulnerability that could lead to arbitrary code execution. (CVE-2018-12841)
  • Multiple integer overflow vulnerabilities that could lead to information disclosure. (CVE-2018-12881, CVE-2018-12842)
  • Multiple buffer overflow vulnerabilities that could lead to arbitrary code execution. (CVE-2018-15951, CVE-2018-12855, CVE-2018-12853)
  • Multiple untrusted pointer dereference vulnerabilities that could lead to arbitrary code execution. (CVE-2018-15937, CVE-2018-15931, CVE-2018-15930)
  • A security bypass vulnerability that could lead to privilege escalation. (CVE-2018-15966)

Successful exploitation of the most severe of these vulnerabilities could result in the attacker gaining control of the affected system. Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

Actions: 
  • After appropriate testing, immediately install the updates provided by Adobe.
  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.
  • Remind users not to visit websites or follow links provided by unknown or untrusted sources.
  • Inform and educate users regarding the threats posed by hypertext links contained in emails or attachments especially from un-trusted sources.
  • Apply the Principle of Least Privilege to all systems and services.
References: 

Adobe:

https://helpx.adobe.com/security/products/acrobat/apsb18-30.html

 

CVE:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12759

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12769

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12831

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12832

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12833

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12834

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12835

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12836

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12837

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12838

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12839

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12841

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12842

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12843

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12844

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12845

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12846

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12847

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12851

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12852

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12853

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12855

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12856

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12857

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12858

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12859

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12860

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12861

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12862

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12863

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12864

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12865

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12866

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12867

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12868

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12869

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12870

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12871

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12872

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12873

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12874

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12875

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12876

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12877

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12878

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12879

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12880

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12881

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15920

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15922

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15923

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15924

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15925

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15926

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15927

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15928

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15929

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15930

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15931

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15932

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15933

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15934

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15935

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15936

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15937

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15938

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15939

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15940

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15941

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15942

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15943

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15944

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15945

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15946

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15947

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15948

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15949

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15950

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15951

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15952

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15953

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15954

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15955

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15956

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15966

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15968