Multiple Vulnerabilities in Adobe Products Could Allow for Arbitrary Code Execution

ITS Advisory Number: 
2021-088 - UPDATED
Date(s) Issued: 
Tuesday, July 13, 2021
Date Updated: 
Thursday, July 22, 2021
Subject: 
Multiple Vulnerabilities in Adobe Products Could Allow for Arbitrary Code Execution
Overview: 

Multiple vulnerabilities have been discovered in Adobe Products, the most severe of which could allow for arbitrary code execution.

 

  • Dimension is a 3D rendering and design software.
  • Illustrator is a vector graphics editor and design program.
  • Adobe Framemaker is a document processing software used to write and edit large or complex documents.
  • Acrobat and Reader is a family of application software and Web services mainly used to create, view, and edit PDF documents.
  • Bridge is a free digital asset management app. It is a mandatory component of Adobe Creative Suite, Adobe eLearning Suite, Adobe Technical Communication Suite and Adobe Photoshop CS2 through CS6.

 

July 22 - UPDATED OVERVIEW:

 

  • Photoshop is Adobe's flagship image editing software.
  • Premiere Pro is a video editing software.
  • After Effects is a graphics and visual effects software.
  • Audition is a professional audio editing application that includes a non-destructive mixing and editing environment.
  • Animator is a motion capture and animation tool that gives everyone a solution for intuitive animation.
  • Prelude software is a video ingest and logging tool that helps you quickly tag and transcode raw footage from file-based cameras.
  • Media Encoder is a software program by Adobe that is used to provide media content for the web and other sources.

Successful exploitation of the most severe of these vulnerabilities could allow for arbitrary code execution. Depending on the privileges associated with the user, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than those who operate with administrative user rights.

 

THREAT INTELLIGENCE:

There are currently no reports of these vulnerabilities being exploited in the wild.

 

Systems Affected: 
  • Adobe Dimension 3.4 and earlier versions
  • Adobe Illustrator 2021 25.2.3 and earlier versions
  • Adobe Framemaker 2019 Update 8 and earlier
  • Adobe Framemaker 2020 Release Update 1 and earlier
  • Acrobat DC 2021.005.20054 and earlier versions  
  • Acrobat Reader DC 2021.005.20054 and earlier versions
  • Acrobat 2020 2020.004.30005 and earlier versions
  • Acrobat Reader 2020 2020.004.30005 and earlier versions
  • Acrobat 2017 2017.011.30197 and earlier versions
  • Acrobat Reader 2017 2017.011.30197 and earlier versions
  • Adobe Bridge 11.0.2 and earlier versions

July 22 - UPDATED SYSTEMS AFFECTED:

 

  • Adobe Photoshop 2020 21.2.9 and earlier versions
  • Adobe Photoshop 2021 22.4.2 and earlier versions
  • Adobe Audition 14.2 and earlier versions
  • Adobe Character Animator 2020 4.2 and earlier versions
  • Adobe Prelude 10.0 and earlier versions
  • Adobe Premiere Pro 15.2 and earlier versions
  • Adobe After Effects 18.2.1 and earlier versions
  • Adobe Media Encoder 15.2 and earlier versions
RISK
GOVERNMENT
Large and medium government entities: 
Medium
Small government entities: 
Medium
BUSINESS
Large and medium business entities: 
Medium
Small business entities: 
Medium
Home Users: 
Low
Description: 

Multiple vulnerabilities have been discovered in Adobe Products, the most severe of which could allow for arbitrary code execution. Details of these vulnerabilities are as follows:

Adobe Dimension:

  • Uncontrolled Search Path Element, which could allow for arbitrary code execution. (CVE-2021-28595)

 

Adobe Illustrator:

  • Out-of-bounds write vulnerability, which could allow for arbitrary code execution. (CVE-2021-28591, CVE-2021-28592)
  • Use After Free vulnerability, which could allow for arbitrary file system read. (CVE-2021-28593)

 

Adobe Framemaker:

  • Out-of-bounds write vulnerability, which could allow for arbitrary code execution. (CVE-2021-28596)

 

Acrobat and Reader:

  • Path Traversal vulnerability, which could allow for arbitrary file system read. (CVE-2021-35980, CVE-2021-28644)
  • Use After Free vulnerabilities, which could allow for arbitrary code execution. (CVE-2021-28640, CVE-2021-28641, CVE-2021-28639, CVE-2021-35983, CVE-2021-35981, CVE-2021-28635)
  • Type Confusion vulnerability, which could allow for arbitrary code execution. ( CVE-2021-28643)
  • Out-of-bounds Write vulnerability, which could allow for arbitrary file system write. (CVE-2021-28642)
  • Out-of-bounds Read vulnerability, which could allow for a memory leak. (CVE-2021-28637)
  • Heap-based Buffer Overflow vulnerability, which could allow for arbitrary code execution. (CVE-2021-28638)
  • Uncontrolled Search Path Element vulnerability, which could allow for arbitrary code execution. (CVE-2021-28636)
  • OS Command Injection vulnerability, which could allow for arbitrary code execution. (CVE-2021-28634)
  • Out-of-bounds Read, vulnerability, which could allow for privilege escalation. (CVE-2021-35988, CVE-2021-35987)
  • Type Confusion vulnerability, which could allow for arbitrary file system read. (CVE-2021-35986)
  • NULL Pointer Dereference vulnerability, which could allow for application denial-of-service. (CVE-2021-35985, CVE-2021-35984)

 

Adobe Bridge:

  • Heap-based Buffer Overflow vulnerability, which could allow for arbitrary code execution. (CVE-2021-28624)
  • Improper Input Validation vulnerability, which could allow for arbitrary code execution. (CVE-2021-35991)
  • Out-of-bounds Write vulnerability, which could allow for arbitrary code execution. (CVE-2021-35989, CVE-2021-35990)
  • Out-of-bounds Read vulnerability, which could allow for arbitrary file system read. (CVE-2021-35992)

 

 

July 22 - UPDATED DESCRIPTION:

 

Adobe Photoshop:

  • Stack-based buffer overflow vulnerability, which could allow for arbitrary code execution (CVE-2021-36005)
  • Improper Input Validation vulnerability, which would allow for arbitrary file system read (CVE-2021-36006)

 

Adobe Audition:

  • Out-of-bounds read vulnerability, which could allow for arbitrary code execution (CVE-2021-36003)

 

Adobe Character Animator:

  • Out-of-bounds read vulnerability, which could allow for privilege escalation (CVE-2021-36001)
  • Access of Memory Location After End of Buffer vulnerability, which could allow for arbitrary code execution (CVE-2021-36000)

 

Adobe Prelude:

  • Improper Input Validation vulnerability, which could allow for arbitrary code execution (CVE-2021-36007)
  • Access of Memory Location After End of Buffer vulnerability, which could allow for arbitrary code execution (CVE-2021-35999)

 

Adobe Premiere Pro:

  • Access of Memory Location After End of Bugger vulnerability, which could allow for arbitrary code execution (CVE-2021-35997)

 

Adobe After Effects:

  • Out-of-bounds read vulnerability, which could allow for arbitrary file system read (CVE-2021-36018-19)
  • Access of Memory Location After End of Buffer vulnerability, which could allow for arbitrary code execution (CVE-2021-36017, CVE-2021-35996)
  • Out-of-bounds write vulnerability, which could allow for arbitrary code execution (CVE-2021-35993-94)
  • Improper Input Validation vulnerability, which could allow for arbitrary code execution (CVE-2021-35995)

 

Adobe Media Encoder:

  • Out-of-bounds read vulnerability, which could allow for arbitrary code execution (CVE-2021-28589-90, CVE-2021-36013, CVE-2021-36016)
  • Improper Input Validation vulnerability, which could allow for arbitrary code execution (CVE-2021-36014)
  • Access of Memory Location After End of Buffer vulnerability, which could allow for arbitrary code execution (CVE-2021-36015)

 

Successful exploitation of the most severe of these vulnerabilities could allow for arbitrary code execution. Depending on the privileges associated with the user an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than those who operate with administrative user rights.

 

Actions: 
  • After appropriate testing, immediately install the updates provided by Adobe.
  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.
  • Remind users not to visit un-trusted websites or follow links provided by unknown or un-trusted sources.
  • Inform and educate users regarding the threats posed by hypertext links contained in emails or attachments especially from un-trusted sources.
  • Apply the Principle of Least Privilege to all systems and services.
References: 

Adobe:
https://helpx.adobe.com/security/security-bulletin.html
https://helpx.adobe.com/security/products/dimension/apsb21-40.html
https://helpx.adobe.com/security/products/illustrator/apsb21-42.html
https://helpx.adobe.com/security/products/framemaker/apsb21-45.html
https://helpx.adobe.com/security/products/acrobat/apsb21-51.html
https://helpx.adobe.com/security/products/bridge/apsb21-53.html

CVE:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28591
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28592
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28593
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28595
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28596
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28624
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28634
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28635
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28636
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28637
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28638
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28639
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28640
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28641
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28642
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28643
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28644
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35980
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35981
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35983
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35984
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35985
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35986
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35987
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35988
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35989
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35990
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35991
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35992
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35993
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35994
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35995
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35997
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35999
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36000
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36001
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36003
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36005
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36006
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36007
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36013
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36014
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36015
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36016
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36017
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36018
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36019

July 22 – UPDATED REFERENCES:
Adobe:
https://helpx.adobe.com/security/products/media-encoder/apsb21-43.html
https://helpx.adobe.com/security/products/after_effects/apsb21-54.html
https://helpx.adobe.com/security/products/premiere_pro/apsb21-56.html
https://helpx.adobe.com/security/products/prelude/apsb21-58.html
https://helpx.adobe.com/security/products/character_animator/apsb21-59.html
https://helpx.adobe.com/security/products/audition/apsb21-62.html
https://helpx.adobe.com/security/products/photoshop/apsb21-63.html

CVE:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28589-90
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35993-94
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35995
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35996
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35997
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35999
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36000
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36001
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36003
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36005
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36006
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36007
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36013
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36014
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36015
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36016
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36017
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-36018-19