Multiple Vulnerabilities in Google Android OS Could Allow for Remote Code Execution

ITS Advisory Number: 
2018-112
Date(s) Issued: 
Tuesday, November 6, 2018
Subject: 
Multiple Vulnerabilities in Google Android OS Could Allow for Remote Code Execution
Overview: 

Multiple vulnerabilities have been discovered in the Google Android operating system (OS), the most severe of which could allow for remote code execution. Android is an operating system developed by Google for mobile devices, including, but not limited to, smartphones, tablets, and watches. Successful exploitation of the most severe of these vulnerabilities could allow for remote code execution within the context of a privileged process. Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

 

THREAT INTELLIGENCE:

There are currently no reports of these vulnerabilities being exploited in the wild.

Systems Affected: 
  • Android OS builds utilizing Security Patch Levels issued prior to November 5, 2018.

RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
BUSINESS
Large and medium business entities: 
High
Small business entities: 
High
Home Users: 
High
Description: 

Multiple vulnerabilities have been discovered in Google Android OS, the most severe of which could allow for remote code execution within the context of a privileged process. Details of these vulnerabilities are as follows: 

  • Multiple elevation of privilege vulnerabilities in Framework. (CVE-2018-9522, CVE-2018-9523, CVE-2018-9524, CVE-2018-9525)

  • An information disclosure vulnerability in Framework. (CVE-2018-9526)

  • Multiple arbitrary code vulnerabilities in Media framework. (CVE-2018-9521, CVE-2018-9527, CVE-2018-9531)

  • Multiple elevation of privilege vulnerabilities in Media framework. (CVE-2018-9536, CVE-2018-9537, CVE-2018-9539)

  • Multiple N/Multiple vulnerabilities in Qualcomm closed-source components. (CVE-2016-10502, CVE-2017-18315, CVE-2017-18316, CVE-2017-18317, CVE-2017-18318, CVE-2018-5870, CVE-2018-5877, CVE-2018-5912, CVE-2018-5916, CVE-2018-5917, CVE-2018-11264, CVE-2018-11994, CVE-2018-11996, CVE-2018-11269)

  • Multiple N/Multiple vulnerabilities in Qualcomm components. (CVE-2017-15818, CVE-2018-11905, CVE-2018-11995)

  • Multiple information disclosure vulnerabilities in System. (CVE-2018-9540, CVE-2018-9541, CVE-2018-9542, CVE-2018-9543, CVE-2018-9544, CVE-2018-9545)

  • A denial of service vulnerability in Update: Media framework. (CVE-2018-9347)

  • An elevation of privilege vulnerability in Update: System. (CVE-2018-9457) 

Successful exploitation of the most severe of these vulnerabilities could allow for remote code execution in the context of a privileged process. These vulnerabilities could be exploited through multiple methods such as email, web browsing, and MMS when processing media files. Depending on the privileges associated with the application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

Actions: 
  • After appropriate testing, immediately apply updates by Google Android or mobile carriers to vulnerable systems when they become available.

  • Remind users to only download applications from trusted vendors in the Play Store.

  • Remind users not to visit un-trusted websites or follow links provided by unknown or un-trusted sources.

  • Inform and educate users regarding threats posed by hypertext links contained in emails or attachments, especially from un-trusted sources.

References: 

Google Android:
http://source.android.com/security/bulletin/2018-11-01.html

CVE:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-10502
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15818
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-18315
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-18316
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-18317
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-18318
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5870
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5877
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5912
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5916
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5917
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9347
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9457
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9521
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9522
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9523
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9524
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9525
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9526
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9527
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9531
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9536
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9537
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9539
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9540
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9541
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9542
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9543
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9544
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-9545
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11264
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11269
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11905
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11994
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11995
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-11996