Multiple Vulnerabilities in Adobe Acrobat and Reader Could Allow for Arbitrary Code Execution (APSB18-41)

ITS Advisory Number: 
2018-126
Date(s) Issued: 
Tuesday, December 11, 2018
Subject: 
Multiple Vulnerabilities in Adobe Acrobat and Reader Could Allow for Arbitrary Code Execution (APSB18-41)
Overview: 

Multiple vulnerabilities have been discovered in Adobe Acrobat and Adobe Reader, the most severe of which could allow for remote code execution. Adobe Acrobat and Reader allow a user to view, create, manipulate, print and manage files in Portable Document Format (PDF). Successful exploitation of the most severe of these vulnerabilities could result in the attacker gaining control of the affected system. Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

 

THREAT INTELLIGENCE:

There are no reports of these vulnerabilities being exploited in the wild.

Systems Affected: 
  • Acrobat DC (Continuous Track) for Windows and macOS version 2019.008.20081 and prior

  • Acrobat Reader DC (Continuous Track) for Windows and macOS version 2019.008.20081 and prior

  • Acrobat 2017 (Classic 2017 Track) for Windows and macOS version 2017.011.30106 and prior

  • Acrobat Reader 2017 (Classic 2017 Track) for Windows and macOS version 2017.011.30106 and prior

  • Acrobat DC (Classic 2015 Track) for Windows and macOS version 2015.006.30457 and prior

  • Acrobat Reader DC (Classic 2015 Track) for Windows and macOS version 2015.006.30457 and prior

RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
Medium
BUSINESS
Large and medium business entities: 
High
Small business entities: 
Medium
Home Users: 
Low
Description: 

Multiple vulnerabilities have been discovered in Adobe Acrobat and Adobe Reader, the most severe of which could allow for arbitrary code execution. The vulnerabilities are as follows: 

  • Multiple buffer errors that could lead to arbitrary code execution. (CVE-2018-15998, CVE-2018-15987)

  • Multiple untrusted pointer deference vulnerabilities that could lead to arbitrary code execution. (CVE-2018-16004, CVE-2018-19720)

  • Multiple security bypass vulnerabilities that could lead to privilege escalation. (CVE-2018-16045, CVE-2018-16044, CVE-2018-16018)

  • Multiple use after free vulnerabilities that could lead to arbitrary code execution. (CVE-2018-19715, CVE-2018-19713, CVE-2018-19708, CVE-2018-19707, CVE-2018-19700, CVE-2018-19698, CVE-2018-16046, CVE-2018-16040, CVE-2018-16039, CVE-2018-16037, CVE-2018-16036, CVE-2018-16029, CVE-2018-16027, CVE-2018-16026, CVE-2018-16025, CVE-2018-16014, CVE-2018-16011, CVE-2018-16008, CVE-2018-16003, CVE-2018-15994, CVE-2018-15993, CVE-2018-15992, CVE-2018-15991, CVE-2018-15990)

  • Multiple out-of-bounds write vulnerabilities that could lead to arbitrary code execution. (CVE-2018-19702, CVE-2018-16016, CVE-2018-16000, CVE-2018-15999, CVE-2018-15988)

  • Multiple heap overflow vulnerabilities that could lead to arbitrary code execution. (CVE-2018-19716, CVE-2018-16021, CVE-2018-12830)

  • Multiple out-of-bounds read vulnerabilities that could lead to information disclosure. (CVE-2018-19717, CVE-2018-19714, CVE-2018-19712, CVE-2018-19711, CVE-2018-19710, CVE-2018-19709, CVE-2018-19706, CVE-2018-19705, CVE-2018-19704, CVE-2018-19703, CVE-2018-19701, CVE-2018-19699, CVE-2018-16047, CVE-2018-16043, CVE-2018-16041, CVE-2018-16038, CVE-2018-16035, CVE-2018-16034, CVE-2018-16033, CVE-2018-16032, CVE-2018-16031, CVE-2018-16030, CVE-2018-16028, CVE-2018-16024, CVE-2018-16023, CVE-2018-16022, CVE-2018-16020, CVE-2018-16019, CVE-2018-16017, CVE-2018-16015, CVE-2018-16013, CVE-2018-16012, CVE-2018-16010, CVE-2018-16006, CVE-2018-16005, CVE-2018-16002, CVE-2018-16001, CVE-2018-15997, CVE-2018-15996, CVE-2018-15989, CVE-2018-15985, CVE-2018-15984, CVE-2018-19719)

  • Multiple integer overflow vulnerabilities that could lead to information disclosure. (CVE-2018-16009, CVE-2018-16007, CVE-2018-15995, CVE-2018-15986)

  • A security bypass vulnerability that could lead to information disclosure. (CVE-2018-16042) 

Successful exploitation of the most severe of these vulnerabilities could result in the attacker gaining control of the affected system. Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

Actions: 
  • After appropriate testing, immediately install the updates provided by Adobe.

  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.

  • Remind users not to visit websites or follow links provided by unknown or untrusted sources.

  • Inform and educate users regarding the threats posed by hypertext links contained in emails or attachments especially from un-trusted sources.

  • Apply the Principle of Least Privilege to all systems and services.

References: 

Adobe:
https://helpx.adobe.com/security/products/acrobat/apsb18-41.html

CVE:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12830
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15986
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15987
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15988
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15990
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15991
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15992
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15993
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15994
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15995
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15998
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-15999
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16000
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16003
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16004
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16007
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16008
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16009
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16011
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16014
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16016
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16018
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16021
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16025
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16026
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16027
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16029
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16036
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16037
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16039
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16040
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16042
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16044
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16045
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16046
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19698
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19700
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19702
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19707
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19708
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19710
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19711
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19712
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19713
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19714
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19715
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19716
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19717
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-19720