Multiple Vulnerabilities in Adobe Products Could Allow for Arbitrary Code Execution

ITS Advisory Number: 
2022-053
Date(s) Issued: 
Wednesday, April 13, 2022
Subject: 
Multiple Vulnerabilities in Adobe Products Could Allow for Arbitrary Code Execution
Overview: 

Multiple vulnerabilities have been discovered in Adobe products, the most severe of which could allow for arbitrary code execution.

  • Adobe Acrobat and Reader are used to view, create, print, and manage PDF files
  • Adobe Commerce is an offering that provides companies with a flexible and scalable end-to-end plate form to manage commerce experiences of their customers
  • Adobe Photoshop is a graphics editor.
  • Adobe After Effects is a digital visual effects, motion graphics, and compositing application.

Successful exploitation of the most severe of these vulnerabilities could allow for arbitrary code execution. Depending on the privileges associated with the user, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than those who operate with administrative user rights.

THREAT INTELLIGENCE:

There are currently no reports of these vulnerabilities being exploited in the wild.

 

Systems Affected: 
  • Photoshop 2021 22.5.6 and earlier versions for Windows and macOS.
  • Photoshop 2022 23.2.2 and earlier versions for Windows and macOS.
  • Adobe After Effects 22.2.1 and earlier versions for Windows and macOS.
  • Adobe After Effects 18.4.5 and earlier versions for Windows and macOS.
  • Adobe Commerce 2.4.3-p1 and earlier versions for Windows and macOS
  • Adobe Commerce 2.3.7-p2 and earlier versions for Windows and macOS
  • Magento Open Source 2.4.3-p1 and earlier versions for Windows and macOS
  • Magento Open Source 2.3.7-p2 and earlier versions for Windows and macOS
  • Adobe DC 22.001.20085 and earlier versions for Windows and macOS
  • Adobe Reader DC 22.001.20085 and earlier versions for Windows and macOS
  • Adobe Acrobat 2020, 20.005.30314 and earlier versions (Windows)
  • Adobe Acrobat 2020, 20.005.30311 and earlier versions (macOS)
  • Adobe Acrobat Reader 2020, 20.005.303.14 and earlier versions (Windows)
  • Adobe Acrobat Reader 2020, 20.005.30311 and earlier versions (macOS)
  • Adobe Acrobat 2017, 17.012.30205 and earlier versions (Windows and macOS)
  • Adobe Acrobat Reader 2017, 17.012.30205 and earlier versions (Windows and macOS)
RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
Medium
BUSINESS
Large and medium business entities: 
High
Small business entities: 
Medium
Home Users: 
Low
Description: 

Multiple vulnerabilities have been discovered in Adobe Products, the most severe of which could allow for arbitrary code execution. Details of these vulnerabilities are as follows:

Adobe Commerce

  • Improper Input Validation (CVE-2022-24093)

 

Adobe Photoshop

  • Out-of-bounds Write (CVE-2022-28270, CVE-2022-28272, CVE-2022-28273, CVE-2022-28275, CVE-2022-28276, CVE-2022-28277, CVE-2022-28278, CVE-2022-24105, CVE-2022-23205)
  • Use After Free (CVE-2022-28271, CVE-2022-28279)
  • Out-of-bounds Read (CVE-2022-28274)
  • Improper Input Validation (CVE-2022-24098)

 

Adobe Acrobat and Reader

  • Use After Free (CVE-2022-24101, CVE-2022-24103, CVE-2022-24104, CVE-2022-27785, CVE-2022-24102, CVE-2022-27786, CVE-2022-27789, CVE-2022-27790, CVE-2022-27795, CVE-2022-27796, CVE-2022-27797, CVE-2022-27800, CVE-2022-27801, CVE-2022-27802, CVE-2022-28230, CVE-2022-28232, CVE-2022-28233, CVE-2022-28235, CVE-2022-28237, CVE-2022-28238, CVE-2022-28240, CVE-2022-28242, CVE-2022-28250, CVE-2022-28256, CVE-2022-28269)
  • Out-of-bounds Write (CVE-2022-27787, CVE-2022-27788, CVE-2022-27793, CVE-2022-27798, CVE-2022-28236)
  • Stack-based Overflow (CVE-2022-27791)
  • Access of Uninitialized Pointer (CVE-2022-27794)
  • Out-of-bounds Read (CVE-2022-28231, CVE-2022-28239, CVE-2022-28241, CVE-2022-28243, CVE-2022-28245, CVE-2022-28246, CVE-28248, CVE-2022-28249, CVE-2022-28251, CVE-2022-28252, CVE-2022-28253, CVE-2022-28254, CVE-2022-28255, CVE-2022-28257, CVE-2022-28258, CVE-2022-28259, CVE-2022-28260, CVE-2022-28261, CVE-2022-28262, CVE-2022-28263, CVE-2022-28264, CVE-2022-28265, CVE-2022-28266, CVE-2022-28267, CVE-2022-28268)
  • Heap-based Buffer Overflow (CVE-2022-28234)
  • Violation of Secure Design Principles (CVE-2022-28244)
  • Missing Support for Integrity Check (CVE-2022-28247)

Adobe After Effects

  • Multiple stack-based buffer overflow vulnerabilities (CVE-2022-27783,CVE-2022-27784)

Successful exploitation of the most severe of these vulnerabilities could allow for arbitrary code execution. Depending on the privileges associated with the user an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than those who operate with administrative user rights.

Actions: 

We recommend the following actions be taken:

  • Install the updates provided by Adobe immediately after appropriate testing.
  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.
  • Remind users not to visit un-trusted websites or follow links provided by unknown or un-trusted sources.
  • Inform and educate users regarding the threats posed by hypertext links contained in emails or attachments especially from un-trusted sources.
  • Apply the Principle of Least Privilege to all systems and services.
References: 

Adobe:
https://helpx.adobe.com/security/security-bulletin.html
https://helpx.adobe.com/security/products/magento/apsb22-13.html
https://helpx.adobe.com/security/products/acrobat/apsb22-16.html
https://helpx.adobe.com/security/products/after_effects/apsb22-19.html
https://helpx.adobe.com/security/products/photoshop/apsb22-20.html

CVE:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-23205
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24093
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24098
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24101
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24102
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24103
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24104
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24105
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27783
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27784
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27785
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27786
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27787
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27788
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27789
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27790
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27791
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27792
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27793
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27794
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27795
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27796
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27797
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27798
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27799
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27800
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27801
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-27802
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28231
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28232
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28233
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28234
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28235
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28236
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28237
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28238
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28239
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28240
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28241
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28242
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28243
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28244
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28245
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28246
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28247
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28248
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28249
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28250
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28251
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28252
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28253
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28254
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28255
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28256
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28257
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28258
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28259
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28260
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28261
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28262
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28263
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28264
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28265
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28266
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28267
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28268
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28269
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28270
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28271
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28272
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28273
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28274
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28275
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28276
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28277
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28278
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28279