Multiple Vulnerabilities in Apple Products Could Allow for Arbitrary Code Execution

ITS Advisory Number: 
2019-119
Date(s) Issued: 
Wednesday, October 30, 2019
Subject: 
Multiple Vulnerabilities in Apple Products Could Allow for Arbitrary Code Execution
Overview: 

Multiple vulnerabilities have been discovered in watchOS, Safari, iOS, iPadOS, macOS Catalina, and tvOS. The most severe of these vulnerabilities could allow for arbitrary code execution.

 

  • tvOS is an operating system for the fourth-generation Apple TV digital media player.
  • iTunes is a media player, media library, online radio broadcaster, and mobile device management application developed by Apple.
  • watchOS is the mobile operating system for the Apple Watch and is based on the iOS operating system.
  • Safari is a web browser available for OS X.
  • iPadOS is the successor to iOS 12 and is a mobile operating system for iPads.
  • iOS is a mobile operating system for mobile devices, including the iPhone, iPad, and iPod touch.

 

Successful exploitation of the most severe of these vulnerabilities could result in arbitrary code execution within the context of the application, an attacker gaining the same privileges as the logged-on user, or the bypassing of security restrictions. Depending on the privileges associated with the user, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

 

THREAT INTELLIGENCE:

There are currently no reports of these vulnerabilities being exploited in the wild.

Systems Affected: 
  • iOS prior to 13.2
  • iPadOS prior to 13.2
  • Safari prior to 13.0.3
  • watchOS prior to 6.1
  • macOS Catalina prior to 10.15.1
  • tvOS prior to 13.2
RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
BUSINESS
Large and medium business entities: 
High
Small business entities: 
High
Home Users: 
Low
Description: 

Multiple vulnerabilities have been discovered in watchOS, Safari, iOS, iPadOS, macOS Catalina, and tvOS. The most severe of these vulnerabilities could allow for arbitrary code execution. Details of these vulnerabilities are as follows:

 

  • A consistency issue existed in deciding when to show the screen recording indicator. The issue was resolved with improved state management. (CVE-2019-8793)
  • A denial of service issue was addressed with improved validation. (CVE-2019-8737)
  • A dynamic library loading issue existed in iTunes setup. This was addressed with improved path searching. (CVE-2019-8801)
  • A logic issue was addressed with improved restrictions. (CVE-2019-8708)
  • A memory consumption issue was addressed with improved memory handling. (CVE-2019-8767)
  • A memory corruption issue existed in the handling of IPv6 packets. This issue was addressed with improved memory management. (CVE-2019-8744)
  • A memory corruption issue was addressed with improved state management. (CVE-2019-8706)
  • A memory corruption vulnerability was addressed with improved locking. (CVE-2019-8747)
  • An authentication issue was addressed with improved state management. (CVE-2019-8803)
  • An inconsistency in Wi-Fi network configuration settings was addressed. (CVE-2019-8804)
  • An inconsistent user interface issue was addressed with improved state management. (CVE-2017-7152)
  • An input validation issue was addressed with improved input validation. (CVE-2019-8736)
  • An issue existed in the parsing of URLs. This issue was addressed with improved input validation. (CVE-2019-8788)
  • An out-of-bounds read was addressed with improved bounds checking. (CVE-2019-8759)
  • An out-of-bounds read was addressed with improved input validation. (CVE-2019-8787)
  • A validation issue existed in the entitlement verification. This issue was addressed with improved validation of the process entitlement. (CVE-2019-8805)
  • A validation issue existed in the handling of symlinks. This issue was addressed with improved validation of symlinks. (CVE-2019-8789)
  • A validation issue was addressed with improved logic. (CVE-2019-8802)
  • Multiple logic issues were addressed with improved state management. (CVE-2019-8764, CVE-2019-8813)
  • Multiple memory corruption issues were addressed with improved input validation. (CVE-2018-12152, CVE-2018-12153, CVE-2018-12154, CVE-2019-8749, CVE-2019-8750, CVE-2019-8756)
  • Multiple memory corruption issues were addressed with improved memory handling. (CVE-2019-8715, CVE-2019-8716, CVE-2019-8784, CVE-2019-8785, CVE-2019-8786, CVE-2019-8795, CVE-2019-8797, CVE-2019-8798, CVE-2019-8807)
  • Multiple memory corruption issues were addressed with improved memory handling. (CVE-2019-8743, CVE-2019-8765, CVE-2019-8766, CVE-2019-8782, CVE-2019-8783, CVE-2019-8808, CVE-2019-8811, CVE-2019-8812, CVE-2019-8814, CVE-2019-8815, CVE-2019-8816, CVE-2019-8819, CVE-2019-8820, CVE-2019-8821, CVE-2019-8822, CVE-2019-8823)
  • Multiple validation issues were addressed with improved input sanitization. (CVE-2019-8794, CVE-2019-8817)
  • The issue was addressed by restricting options offered on a locked device. (CVE-2019-8775)
  • This issue was addressed by removing the vulnerable code. (CVE-2019-8509)
  • This issue was addressed with improved checks. (CVE-2019-8761)
Actions: 
  • After appropriate testing, immediately apply patches provided by Apple to vulnerable systems immediately after appropriate testing.
  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.
  • Remind users not to download, accept, or execute files from un-trusted or unknown sources.
  • Remind users not to visit untrusted websites or follow links provided by unknown or un-trusted sources.
  • Apply the Principle of Least Privilege to all systems and services.
References: 

Apple:

https://support.apple.com/en-us/HT210721

https://support.apple.com/en-us/HT210722

https://support.apple.com/en-us/HT210723

https://support.apple.com/en-us/HT210724

https://support.apple.com/en-us/HT210725

 

CVE:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7152

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8509

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8706

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8708

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8715

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8716

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8736

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8737

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8743

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8744

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8747

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8749

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8750

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8756

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8759

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8761

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8764

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8765

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8766

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8767

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8775

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8782

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8783

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8784

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8785

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8786

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8787

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8788

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8789

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8793

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8794

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8795

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8797

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8798

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8801

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8802

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8803

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8804

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8805

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8807

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8808

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8811

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8812

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8813

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8814

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8815

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8816

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8817

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8819

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8820

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8821

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8822

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8823

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12152

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12153

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12154