Multiple Vulnerabilities in Adobe Acrobat and Reader Could Allow for Arbitrary Code Execution (APSB18-02)

ITS Advisory Number: 
2018-021
Date(s) Issued: 
Tuesday, February 13, 2018
Subject: 
Multiple Vulnerabilities in Adobe Acrobat and Reader Could Allow for Arbitrary Code Execution (APSB18-02)
Overview: 

Multiple vulnerabilities have been discovered in Adobe Acrobat and Reader, the most severe of which could allow for arbitrary code execution. Adobe Acrobat and Reader allow a user to view, create, manipulate, print and manage files in Portable Document Format (PDF). Successful exploitation of the most severe of these vulnerabilities could result in an attacker executing arbitrary code in the context of the affected application. Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

THREAT INTELLIGENCE:

There are currently no reports of these vulnerabilities being exploited in the wild.

Systems Affected: 

 

  • Adobe Acrobat DC (Continuous Track) for Windows and Macintosh versions 2018.009.20050 and earlier

  • Adobe Acrobat Reader DC (Continuous Track) for Windows and Macintosh versions 2018.009.20050 and earlier

  • Adobe Acrobat 2017 for Windows and Macintosh versions 2017.011.30070 and earlier

  • Adobe Acrobat Reader 2017 for Windows and Macintosh versions 2017.011.30070 and earlier

  • Adobe Acrobat DC (Classic Track) for Windows and Macintosh versions 2015.006.30394 and earlier

  • Adobe Acrobat Reader DC (Classic Track) for Windows and Macintosh versions 2015.006.30394 and earlier

RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
Medium
BUSINESS
Large and medium business entities: 
High
Small business entities: 
Medium
Home Users: 
Low
Description: 

Multiple vulnerabilities have been discovered in Adobe Acrobat and Reader, the most severe of which could allow for arbitrary code execution. The vulnerabilities are as follows:

  • One security mitigation bypass vulnerability that could allow for privilege escalation (CVE-2018-4872)
  • Four heap overflow vulnerabilities that could allow for arbitrary code execution (CVE-2018-4890, CVE-2018-4904, CVE-2018-4910, CVE-2018-4917)
  • Five use-after-free vulnerabilities that could allow for arbitrary code execution (CVE-2018-4888, CVE-2018-4892, CVE-2018-4902, CVE-2018-4911, CVE-2018-4913)
  • Seven out-of-bounds write vulnerabilities that could allow for arbitrary code execution (CVE-2018-4879, CVE-2018-4895, CVE-2018-4898, CVE-2018-4901, CVE-2018-4915, CVE-2018-4916, CVE-2018-4918)
  • Twenty-four out-of-bounds read vulnerabilities that could allow for remote code execution (CVE-2018-4880, CVE-2018-4881, CVE-2018-4882, CVE-2018-4883, CVE-2018-4884, CVE-2018-4885, CVE-2018-4886, CVE-2018-4887, CVE-2018-4889, CVE-2018-4891, CVE-2018-4893, CVE-2018-4894, CVE-2018-4896, CVE-2018-4897, CVE-2018-4899, CVE-2018-4900, CVE-2018-4903, CVE-2018-4905, CVE-2018-4906, CVE-2018-4907, CVE-2018-4908, CVE-2018-4909, CVE-2018-4912, CVE-2018-4914)

Successful exploitation of the most severe of these vulnerabilities could result in an attacker executing arbitrary code in the context of the affected application. Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

Actions: 
  • After appropriate testing, immediately install the updates provided by Adobe.

  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.

  • Remind users not to visit websites or follow links provided by unknown or untrusted sources.

  • Inform and educate users regarding the threats posed by hypertext links contained in emails or attachments especially from un-trusted sources.

  • Apply the Principle of Least Privilege to all systems and services.

References: 

Adobe:

https://helpx.adobe.com/security/products/acrobat/apsb18-02.html

 

CVE:

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4872

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4879

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4880

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4881

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4882

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4883

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4884

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4885

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4886

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4887

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4888

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4889

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4890   

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4891

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4892

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4893

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4894

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4895

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4896

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4897

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4898

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4899

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4900

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4901

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4902

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4903

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4904

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4905

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4906   

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4907   

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4908  

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4909  

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4910

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4911

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4912   

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4913

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4914  

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4915

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4916

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4917  

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4918