Multiple Vulnerabilities in Adobe Acrobat and Adobe Reader Could Allow for Remote Code Execution (APSB17-24)

ITS Advisory Number: 
2017-074
Date(s) Issued: 
Tuesday, August 8, 2017
Subject: 
Multiple Vulnerabilities in Adobe Acrobat and Adobe Reader Could Allow for Remote Code Execution (APSB17-24)
Overview: 

Multiple vulnerabilities have been discovered in Adobe Acrobat and Adobe Reader, the most severe of which could allow for remote code execution. Adobe Acrobat and Reader allow a user to view, create, manipulate, print and manage files in Portable Document Format (PDF). Successful exploitation of the most severe of these vulnerabilities could result in the attacker gaining control of the affected system.  Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

Systems Affected: 

Continuous Track:

  • Adobe Acrobat DC versions 2017.009.20058 and prior for Windows and Macintosh
  • Adobe Acrobat Reader DC versions 2017.009.20058 and prior for Windows and Macintosh

 

Acrobat 2017:

  • Acrobat 2017 versions 2017.008.30051 and prior for Windows and Macintosh

  • Acrobat Reader 2017 versions 2017.008.30051 and prior for Windows and Macintosh

 

Classic Track:

  • Adobe Acrobat DC versions 2015.006.30306 and prior for Windows and Macintosh

  • Adobe Acrobat Reader DC versions 2015.006.30306 and prior for Windows and Macintosh

 

Desktop Track:

  • Adobe Acrobat XI versions 11.0.20 and prior for Windows and Macintosh

  • Adobe Reader XI versions 11.0.20 and prior for Windows and Macintosh

RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
Medium
BUSINESS
Large and medium business entities: 
High
Small business entities: 
Medium
Home Users: 
Low
Description: 

Multiple vulnerabilities have been discovered in Adobe Acrobat and Adobe Reader, the most severe of which could allow for remote code execution. Adobe Acrobat and Reader allow a user to view, create, manipulate, print and manage files in Portable Document Format (PDF). Successful exploitation of the most severe of these vulnerabilities could result in the attacker gaining control of the affected system.  Depending on the privileges associated with this application, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. If this application has been configured to have fewer user rights on the system, exploitation of the most severe of these vulnerabilities could have less impact than if it was configured with administrative rights.

Actions: 
  • After appropriate testing, immediately install the updates provided by Adobe.

  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.

  • Remind users not to visit websites or follow links provided by unknown or untrusted sources.

  • Inform and educate users regarding the threats posed by hypertext links contained in emails or attachments especially from un-trusted sources.

  • Apply the Principle of Least Privilege to all systems and services.

References: 

Adobe:

https://helpx.adobe.com/security/products/acrobat/apsb17-24.html

 

CVE:

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3016

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3038

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3113

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3115

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3116

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3117 

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3118

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3119

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3120

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3121

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3122

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3123

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3124

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11209

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11210

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11211

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11212

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11214

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11216

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11217

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11218

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11219

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11220

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11221

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11222

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11223

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11224

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11226

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11227

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11228

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11229

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11230

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11231

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11232

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11233

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11234

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11235

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11236

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11237

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11238

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11239

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11241

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11242

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11243

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11244

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11245

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11246

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11248

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11249

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11251

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11252

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11254

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11255

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11256

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11257

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11258

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11259

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11260

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11261

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11262

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11263

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11265

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11267

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11268

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11269

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11270

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11271