Multiple Vulnerabilities in Adobe Flash Player Could Allow Remote Code Execution (APSB15-32)

ITS Advisory Number: 
2015-151
Date(s) Issued: 
Tuesday, December 8, 2015
Subject: 
Multiple Vulnerabilities in Adobe Flash Player Could Allow Remote Code Execution (APSB15-32)
Overview: 

Multiple vulnerabilities have been discovered in Adobe Flash Player, a widely distributed multimedia and application player used to enhance the user experience when visiting web pages or reading email messages. Successful exploitation of this vulnerability could result in an attacker gaining the same privileges as the logged on user. Depending on the privileges associated with the user, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

Systems Affected: 
  • Adobe Flash Player Desktop Runtime 19.0.0.245 and earlier  Windows and Macintosh
  • Adobe Flash Player Extended Support Release 18.0.0.261 and earlier Windows and Macintosh
  • Adobe Flash Player for Google Chrome 19.0.0.245 and earlier Windows, Macintosh, Linux and ChromeOS
  • Adobe Flash Player for Microsoft Edge and Internet Explorer 11 19.0.0.245 and earlier Windows 10
  • Adobe Flash Player for Internet Explorer 10 and 11 19.0.0.245 and earlier Windows 8.0 and 8.1
  • Adobe Flash Player for Linux 11.2.202.548 and earlier Linux
  • AIR Desktop Runtime 19.0.0.241 and earlier Windows and Macintosh
  • AIR SDK 19.0.0.241 and earlier Windows, Macintosh, Android and iOS
  • AIR SDK & Compiler 19.0.0.241 and earlier Windows, Macintosh, Android and iOS
  • AIR for Android 19.0.0.241 and earlier Android
RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
BUSINESS
Large and medium business entities: 
High
Small business entities: 
High
Home Users: 
High
Description: 

Adobe Flash Player is prone to multiple vulnerabilities. These vulnerabilities are as follows:

  • A heap buffer overflow vulnerabilities that could lead to code execution (CVE-2015-8438, CVE-2015-8446).
  • A memory corruption vulnerabilities that could lead to code execution (CVE-2015-8444, CVE-2015-8443, CVE-2015-8417, CVE-2015-8416, CVE-2015-8451, CVE-2015-8047, CVE-2015-8053, CVE-2015-8045, CVE-2015-8051, CVE-2015-8060, CVE-2015-8419, CVE-2015-8408).
  • A security bypass vulnerabilities (CVE-2015-8453, CVE-2015-8440, CVE-2015-8409).
  • A stack overflow vulnerability that could lead to code execution (CVE-2015-8407).
  • A type confusion vulnerability that could lead to code execution (CVE-2015-8439).
  • An integer overflow vulnerability that could lead to code execution (CVE-2015-8445).
  • A buffer overflow vulnerability that could lead to code execution (CVE-2015-8415)
  • Use-after-free vulnerabilities that could lead to code execution (CVE-2015-8050, CVE-2015-8049, CVE-2015-8437, CVE-2015-8450, CVE-2015-8449, CVE-2015-8448, CVE-2015-8436, CVE-2015-8452, CVE-2015-8048, CVE-2015-8413, CVE-2015-8412, CVE-2015-8410, CVE-2015-8411, CVE-2015-8424, CVE-2015-8422, CVE-2015-8420, CVE-2015-8421, CVE-2015-8423, CVE-2015-8425, CVE-2015-8433, CVE-2015-8432, CVE-2015-8431, CVE-2015-8426, CVE-2015-8430, CVE-2015-8427, CVE-2015-8428, CVE-2015-8429, CVE-2015-8434, CVE-2015-8435, CVE-2015-8414, CVE-2015-8052, CVE-2015-8059, CVE-2015-8058, CVE-2015-8055, CVE-2015-8057, CVE-2015-8056, CVE-2015-8061, CVE-2015-8067, CVE-2015-8066, CVE-2015-8062, CVE-2015-8068, CVE-2015-8064, CVE-2015-8065, CVE-2015-8063, CVE-2015-8405, CVE-2015-8404, CVE-2015-8402, CVE-2015-8403, CVE-2015-8071, CVE-2015-8401, CVE-2015-8406, CVE-2015-8069, CVE-2015-8070, CVE-2015-8441, CVE-2015-8442, CVE-2015-8447).

Successful exploitation of these vulnerabilities could result in an attacker gaining the same privileges as the logged on user. Depending on the privileges associated with the user, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

Actions: 
  • Install the updates provided by Adobe immediately after appropriate testing.
  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.
  • Remind users not to visit un-trusted websites or follow links provided by unknown or un-trusted sources.
  • Inform and educate users regarding the threats posed by hypertext links contained in emails or attachments, especially those from un-trusted sources.
References: 

Adobe:

https://helpx.adobe.com/security/products/flash-player/apsb15-32.html

CVE

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8438

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8446

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8444

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8443

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8417

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8416

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8451

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8047

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8053

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8045

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8051

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8060

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8419

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8408

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8453

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8440

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8409

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8407

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8439

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8445

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8415

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8050

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8049

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8437

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8450

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8449

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8448

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8436

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8452

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8048

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8413

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8412

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8410

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8411

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8424

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8422

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8420

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8421

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8423

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8425

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8433

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8432

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8431

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8426

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8430

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8427

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8428

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8429

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8434

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8435

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8414

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8052

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8059

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8058

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8055

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8057

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8056

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8061

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8067

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8066

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8062

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8068

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8064

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8065

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8063

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8405

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8404

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8402

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8403

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8071

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8401

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8406

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8069

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8070

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8441

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8442

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8447