Multiple Vulnerabilities in PHP Could Allow for Arbitrary Code Execution

ITS Advisory Number: 
2019-089
Date(s) Issued: 
Tuesday, September 3, 2019
Subject: 
Multiple Vulnerabilities in PHP Could Allow for Arbitrary Code Execution
Overview: 

Multiple vulnerabilities have been discovered in PHP, the most severe of which could allow for arbitrary code execution. PHP is a programming language originally designed for use in web-based applications with HTML content. PHP supports a wide variety of platforms and is used by numerous web-based software applications. Successfully exploiting the most severe of these vulnerabilities could allow for arbitrary code execution in the context of the affected application. Depending on the privileges associated with the application, an attacker could install programs; view, change, or delete data; or create new accounts with full user rights. Failed exploitation could result in a denial-of-service condition.

 

THREAT INTELLIGENCE:

There are currently no reports of these vulnerabilities being exploited in the wild.

 

Systems Affected: 
  • PHP 7.1 prior to 7.1.32

  • PHP 7.2 prior to 7.2.22

  • PHP 7.3 prior to 7.3.9

RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
BUSINESS
Large and medium business entities: 
High
Small business entities: 
High
Home Users: 
Low
Description: 

Multiple vulnerabilities have been discovered in PHP, the most severe of which could allow for arbitrary code execution. Details of these vulnerabilities are as below:

 

Version 7.3.9:

  • Bug (Buffer overflow in zendparse)
  • Bug (Cast to object confuses GC, causes crash)
  • Bug (Generator incorrectly reports non-releasable $this as GC child)
  • Bug (Bad cURL resources returned by curl_multi_info_read()
  • Bug (Exif crash (bus error)
  • Bug (Use-after-free in FPM master event handling)
  • Bug (Bus error in configure test for iconv //IGNORE)
  • Bug (Oniguruma 6.9.3 fixes CVEs)
  • Bug (MariaDB server version incorrectly detected)
  • Bug (Empty row pocket)
  • Bug (Assertion failure in dce_live_ranges()
  • Bug (Bus error from stream_copy_to_stream (file -> SSL stream)
  • Bug (atime and mtime mismatch)
  • Bug (improper memory deallocation on stream_get_contents()
  • Bug (strip_tags no longer handling nested php tags)

 

Version 7.2.22:

  • Bug (Buffer overflow in zendparse)
  • Bug (Cast to object confuses GC, causes crash)
  • Bug (Bad cURL resources returned by curl_multi_info_read()
  • Bug (Exif crash (bus error)
  • Bug (Bus error in configure test for iconv //IGNORE)
  • Bug (MariaDB server version incorrectly detected)
  • Bug (Assertion failure in dce_live_ranges()
  • Bug (Bus error from stream_copy_to_stream (file -> SSL stream)
  • Bug (atime and mtime mismatch)
  • Bug (improper memory deallocation on stream_get_contents()

 

Version 7.1.32:

  • Bug (heap use-after-free in pcrelib)

 

Successfully exploiting the most severe of these vulnerabilities could allow for arbitrary code execution in the context of the affected application. Depending on the privileges associated with the application, an attacker could install programs; view, change, or delete data; or create new accounts with full user rights. Failed exploitation could result in a denial-of-service condition.

Actions: 
  • Verify no unauthorized system modifications have occurred on system before applying patch.

  • After appropriate testing, immediately apply the latest upgraded version of PHP.

  • Apply the principle of Least Privilege to all systems and services.

  • Remind users not to visit websites or follow links provided by unknown or untrusted sources.