Multiple Vulnerabilities in PHP Could Allow for Arbitrary Code Execution

ITS Advisory Number: 
2018-085
Date(s) Issued: 
Wednesday, August 22, 2018
Subject: 
Multiple Vulnerabilities in PHP Could Allow for Arbitrary Code Execution
Overview: 

Multiple vulnerabilities have been discovered in PHP, the most severe of which could allow an attacker to execute arbitrary code. PHP is a programming language originally designed for use in web-based applications with HTML content. PHP supports a wide variety of platforms and is used by numerous web-based software applications. Successfully exploiting the most severe of these vulnerabilities could allow for arbitrary code execution in the context of the affected application. Depending on the privileges associated with the application, an attacker could install programs; view, change, or delete data; or create new accounts with full user rights. Failed exploitation could result in a denial-of-service condition.

 

THREAT INTELLIGENCE:

There are currently no reports of these vulnerabilities being exploited in the wild.

Systems Affected: 
  • PHP 7.2 prior to 7.2.9

  • PHP 7.1 prior to 7.1.21

RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
BUSINESS
Large and medium business entities: 
High
Small business entities: 
High
Home Users: 
Low
Description: 

Multiple vulnerabilities have been discovered in PHP, the most severe of which could allow an attacker to execute arbitrary code. Details of these vulnerabilities are as below:

  

Version 7.2.9 & Version 7.1.21:

  • Bug (jewish.c: compile error under Windows with GBK charset).

  • Bug (References in sub-array for filtering breaks the filter).

  • Bug (Memory leak when fetching a BLOB field).

  • Bug (Possible Memory Leak using PDO::CURSOR_SCROLL option).

  • Bug (SQLite3Stmt::bindValue() with SQLITE3_FLOAT doesn't juggle).

  • Bug (Incorrect entries in get_html_translation_table).

  • Bug (array_column: null values in $index_key become incrementing keys in result).

  • Bug (Segmentation fault when using `output_add_rewrite_var`).

  • Bug (ZipArchive memory leak (OVERWRITE flag and empty archive)). 

 

Successfully exploiting the most severe of these vulnerabilities could allow for arbitrary code execution in the context of the affected application. Depending on the privileges associated with the application, an attacker could install programs; view, change, or delete data; or create new accounts with full user rights. Failed exploitation could result in a denial-of-service condition.

Actions: 
  • Verify no unauthorized system modifications have occurred on system before applying patch.

  • After appropriate testing, immediately upgrade to the latest version of PHP.

  • Apply the principle of Least Privilege to all systems and services.

  • Remind users not to visit websites or follow links provided by unknown or untrusted sources.

References: 

NOTE: Visiting these links may trigger an IDS signature match for a Possible Encrypted Webshell Download. This is potentially a false positive alert that is matching content on the pages below.

 

PHP:

http://php.net/ChangeLog-7.php#7.2.9

http://php.net/ChangeLog-7.php#7.1.21