Security Update for Internet Explorer (MS15-112)

ITS Advisory Number: 
2015-136
Date(s) Issued: 
Tuesday, November 10, 2015
Subject: 
Security Update for Internet Explorer (MS15-112)
Overview: 

This security update resolves vulnerabilities in Internet Explorer. The most severe of the vulnerabilities could allow remote code execution if a user views a specially crafted webpage using Internet Explorer. An attacker who successfully exploited these vulnerabilities could gain the same user rights as the current user. Customers whose accounts are configured to have fewer user rights on the system could be less impacted than those who operate with administrative user rights.

Systems Affected: 
  • Internet Explorer 11 on Windows 10
  • Internet Explorer 11
  • Internet Explorer 10
  • Internet Explorer 9
  • Internet Explorer 8
  • Internet Explorer 7
RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
BUSINESS
Large and medium business entities: 
High
Small business entities: 
High
Home Users: 
High
Description: 

The security update addresses the following vulnerabilities:

  • Internet Explorer Memory Corruption Vulnerabilities [CVE-2015-2427, CVE-2015-6065, CVE-2015-6066, CVE-2015-6068, CVE-2015-6069, CVE-2015-6070, CVE-2015-6071, CVE-2015-6072, CVE-2015-6074, CVE-2015- 6075, CVE-2015-6076, CVE-2015-6077, CVE-2015-6079, CVE-2015-6080, CE-2015-6081, CVE-2015-6082, CVE-2015-6084, CVE-2015-6085, CVE-2015-6087]
  • Microsoft Browser Memory Corruption Vulnerabilities: [CVE-2015-6064, CVE-2015-6073, CVE-2015-6078]
  • Internet Explorer Information Disclosure Vulnerability: [CVE-2015-6086]
  • Microsoft Browser ASLR Bypass: [CVE-2015-6088]
  • Scripting Engine Memory Corruption Vulnerability: [CVE-2015-6089]

These vulnerabilities could allow remote code execution or an elevation of privilege if a user views a specially crafted webpage in Internet Explorer. An attacker who successfully exploits this vulnerability could gain the same user rights as the current user. Depending on the privileges associated with the user, an attacker could install programs; view, change, or delete data; or create new accounts with full user rights.

Actions: 
  • After appropriate testing, apply appropriate patches provided by Microsoft to vulnerable systems.
  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.
  • Remind users not to visit untrusted websites or follow links provided by unknown or untrusted sources.
  • Do not open email attachments from unknown or untrusted sources or suspicious emails from trusted sources.
References: 

Microsoft:

https://technet.microsoft.com/library/security/MS15-112

CVE:

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-2424

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6064

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6065

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6066

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6068

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6069

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6070

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6071

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6072

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6073

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6074

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6075

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6076

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6077

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6078

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6079

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6080

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6081

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6082

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6084

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6085

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6086

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6087

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6088

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-6089