Vulnerabilities in Adobe Font Driver Could Allow Remote Code Execution (MS15-021)

ITS Advisory Number: 
2015-024
Date(s) Issued: 
Tuesday, March 10, 2015
Subject: 
Vulnerabilities in Adobe Font Driver Could Allow Remote Code Execution (MS15-021)
Overview: 

Multiple vulnerabilities in Adobe Font Driver could allow remote code execution. Adobe Font Driver allows Windows systems to display a range of fonts to enhance the user experience when visiting web pages or reading documents or email messages. Successful exploitation could result in an attacker compromising data security, potentially allowing access to confidential data, or could compromise processing resources in a user's computer. Failed exploit attempts will likely cause denial-of-service conditions.

Systems Affected: 
  • Windows Vista
  • Windows 7
  • Windows 8
  • Windows 8.1
  • Windows Server 2003
  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows RT
  • Windows RT 8.1
  • Server core
RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
BUSINESS
Large and medium business entities: 
High
Small business entities: 
High
Home Users: 
High
Description: 

Adobe Font Driver is prone to multiple vulnerabilities that could allow for remote code execution. These vulnerabilities are as follows:

  • A denial of service vulnerability due to how the Adobe Font Driver manages memory when parsing fonts. (CVE-2015-0074).
  • Multiple information disclosure vulnerabilities that could allow the disclosure of memory contents to an attacker. (CVE-2015-0087, CVE-2015-0089).
  • Multiple remote code execution vulnerabilities due to the Adobe Font Driver improperly overwriting objects in memory. (CVE-2015-0088, CVE-2015-0090, CVE-2015-0091, CVE-2015-0092, CVE-2015-0093).

Successful exploitation could result in an attacker compromising data security, potentially allowing access to confidential data, or could compromise processing resources in a user's computer. Failed exploit attempts will likely cause denial-of-service conditions.

Actions: 

We recommend the following actions be taken:

  • Apply appropriate patches provided by Microsoft to vulnerable systems immediately after appropriate testing.
  • Run all software as a non-privileged user (one without administrative privileges) to diminish the effects of a successful attack.
  • Remind users not to visit un-trusted websites or follow links provided by unknown or un-trusted sources.
  • Do not open email attachments from unknown or untrusted sources.