A Vulnerability in Apple iOS and iPadOS Could Allow for Arbitrary Code Execution

ITS Advisory Number: 
2021-131
Date(s) Issued: 
Tuesday, October 12, 2021
Subject: 
A Vulnerability in Apple iOS and iPadOS Could Allow for Arbitrary Code Execution
Overview: 

A vulnerability has been discovered in iOS and iPadOS which could allow for arbitrary code execution with kernel privileges. iOS and iPadOS are operating systems for Apple's mobile devices including the iPhone, iPad, and iPod touch. Successful exploitation of this vulnerability would allow an attacker to install programs and view, change, or delete any data due to kernel privileges.

 

THREAT INTELLIGENCE:

Apple has reported that CVE-2021-30883 is being exploited in the wild.

 

Systems Affected: 
  • iOS prior to 15.0.2
  • iPadOS prior to 15.0.2
RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
Medium
BUSINESS
Large and medium business entities: 
High
Small business entities: 
Medium
Home Users: 
Medium
Description: 

An integer overflow vulnerability has been discovered in iOS and iPadOS which could allow for arbitrary code execution with kernel privileges. This has been addressed in the latest patch via improved memory handling.

 

Successful exploitation of this vulnerability would allow an attacker to install programs and view, change, or delete any data due to kernel privileges.

 

Actions: 
  • After appropriate testing, immediately apply patches provided by Apple to vulnerable systems. 
  • Remind users not to download, accept or execute files from untrusted and unknown sources.
  • Remind users not to visit untrusted websites or follow links provided by untrusted or unknown sources.