A Vulnerability in Drupal Could Allow for Remote Code Execution

ITS Advisory Number: 
2018-046
Date(s) Issued: 
Thursday, April 26, 2018
Subject: 
A Vulnerability in Drupal Could Allow for Remote Code Execution
Overview: 

A vulnerability has been discovered in the Drupal core module, which could allow for remote code execution. Drupal is an open source content management system (CMS) written in PHP. Successful exploitation of this vulnerability could allow for remote code execution. Depending on the privileges associated with the user, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than those who operate with administrative user rights.

Systems Affected: 
  • Drupal Core versions prior to 7.59, 8.5.3, and 8.4.8

Note: Drupal versions 8.4.x and earlier are no longer supported. However, Drupal is providing an 8.4.x release that includes the fix for websites that have not yet had a chance to update to 8.5.x. These patches will only work if your site already has the fix from SA-CORE-2018-002 (CVE-2018-7600) applied.

RISK
GOVERNMENT
Large and medium government entities: 
High
Small government entities: 
High
BUSINESS
Large and medium business entities: 
High
Small business entities: 
High
Home Users: 
Low
Description: 

A vulnerability has been discovered in Drupal core module which could allow for remote code execution. The vulnerability exists within several subsytems of Drupal versions that could result in a website being completely compromised.

Successful exploitation of this vulnerability could allow for remote code execution. Depending on the privileges associated with the user, an attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than those who operate with administrative user rights.

Actions: 
  • Ensure no unauthorized system changes have occurred before applying patches.
  • After appropriate testing, immediately apply patches provided by Drupal to vulnerable.
  • Run all software as a non-privileged user to diminish effects of a successful attack.
  • Apply the Principle of Least Privilege to all systems and services. 
  • Drupal version 8.4.x and earlier sites should be migrated to supported Drupal versions as soon as possible after patches are applied.
References: 

Drupal:

; text-decoration:underline">https://www.drupal.org/sa-core-2018-004

CVE: 

; text-decoration:underline">https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-7602